Crashes on startup on two WinXP computers

General questions and suggestions about Motorboat Simulator

Crashes on startup on two WinXP computers

Postby Kaare » Fri 29 May 2009 - 08:30

I cannot get Motorboat to run on two different Windows XP computers.

Computer 1:
Windows XP Pro SP2
Geforce 8500GT graphics card

Computer 2:
Windows XP Pro SP3
Intel GZ946 Chipset with integrated directX 9 graphics card

They both crash when they are about to load the scenery with the following log message:

********************************************************************************
Date : 2009-05-29 08:25:59
File : C:\Programmer\Stentec\Motorboat Simulator 1\MBS1Client.exe
Application : Motorboat Simulator v1.2.0.6
CPU Name : Genuine Intel(R) CPU 2140 @ 1.60GHz
CPU Info : 6.15.2, $000006F2, $BFEBFBFF, MMX, SSE, SSE2, SSE3
Memory : 1014,04 MB
OS : Microsoft Windows XP Professional Service Pack 3 Build 2600 (2.5.1.2600/3.0/$0/$100)
Exception : EAccessViolation
Message : "Access violation at address 00511007 in module 'MBS1Client.exe'. Read of address 00000011"

RTLI generation timestamp: 2004-11-04 14:52:55

Stack trace:
Logical File LineNr Routine
00110007 StD3DLights.<start of unit>
00188AA2 PropulsionUnits.<start of unit>
00174661 InstrChart.pas 1699 InstrChart.TDXChartViewer.SetChart
000EDBF8 StWaveEngines.pas 1164 StWaveEngines.TWaveEngine.FadeIn
000EDC1D StWaveEngines.pas 1184 StWaveEngines.TWaveEngine.GetDepthFactorTriangle
000FE03D StSimLoops.pas 378 StSimLoops.TSimLoop.IdleHandler
000FD955 StSimLoops.<start of unit>
000FD754 StSimLoops.<start of unit>
0005AE8B Forms.TApplication.Idle
0005A468 Forms.TApplication.HandleMessage
001F00F2 FrmMBS1Client.pas 2157 FrmMBS1Client.TFormMBS1Client.Execute
00249A6B FrmMBS1Launch.pas 157 FrmMBS1Launch.TFormMBS1Launch.ButtonMainStartClick
0006AD8E Controls.TControl.Click
001D43DF StButtons.pas 379 StButtons.TImageButton.MouseUp
0006B179 Controls.TControl.DoMouseUp
0006DB40 Controls.TWinControl.WndProc
00026B96 Classes.StdWndProc
0005A424 Forms.TApplication.ProcessMessage
0024B550 MBS1Client.dpr 133 MBS1Client.initialization


I have tried installing DirectX 9 on both of them and update the graphics drivers but this does not help.
Kaare
 
Posts: 5
Joined: Wed 27 May 2009 - 08:46

Re: Crashes on startup on two WinXP computers

Postby Kaare » Mon 08 Jun 2009 - 10:07

I have now tried running the simulator on Windows 7 32-bit with success after i installed the d3drm.dll file.

The only difference i can find on all three installations are the language. On the two computers where the simulator crashes with the above mentioned error, the windows language is danish while it is english on the Windows 7 machine and on my personal machine at home it is also english (Windows XP), those two machines can run the simulator perfectly.

I have written to helpdesk and in this forum and still not received any kind of support regarding this issue, please advise.

Venlig hilsen / Best regards
Kaare Mai, Technical Support
TIMCO Electronic ApS
Kaare
 
Posts: 5
Joined: Wed 27 May 2009 - 08:46

Re: Crashes on startup on two WinXP computers

Postby Bernard » Mon 08 Jun 2009 - 16:30

I've send an e-mail for more information. We can try to solve this issue by e-mail.
Greetings Bernard

Stentec Support Team
Bernard
Site Admin
 
Posts: 201
Joined: Wed 18 Oct 2006 - 07:49
Location: Kollum, The Netherlands

Re: Crashes on startup on two WinXP computers

Postby Kaare » Tue 13 Sep 2011 - 12:47

When can we expect a new updated version of motorboat simulator? This issue has not been fixed still.
Kaare
 
Posts: 5
Joined: Wed 27 May 2009 - 08:46


Return to Motorboat Simulator - General

Who is online

Users browsing this forum: No registered users and 2 guests

cron